Site Requirements

Digipixart currently supports the web browsers below:

  • FireFox (download)
  • Internet Explorer (download)
  • Safari (download)
  • Professional Member features (e.g. Coupon Management) may require
    • FireFox 3.0+
    • Internet Explorer 7.0+
    • Safari 3.0+

Other requirements:

  • Javascript must be enabled
  • Cookies must be enabled for logging in and/or using the shopping cart.
  • Java Plug-in (only for professionals who want to use the Java FTP Applet)